Magento 2.x System Requirements

Since Magento 2 was released, it introduced a user-friendly interface, flexibility, advanced functionalities, and enhanced security for E-commerce websites. Magento 2 versions have all you need to grow your business even faster and control the store in a better way.

To avail of all the benefits, install latest Magento 2 right away and grow your business! Here’s the first step towards installing Magento 2 and the minimum system requirements for installing Magento 2 to move from the older Magento versions! Magento 2 System Requirements include required OS, memory requirements, supported browsers, additional tools to install, and other required settings.

Magento 2 System Requirements

Operating Systems Requirements (Linux x86-64)

Linux distributions, such as RedHat Enterprise Linux (RHEL), CentOS, Ubuntu, Debian, and similar. Magento is not supported on Microsoft Windows and macOS.

RAM Requirement

One will need up to 2GB RAM to update Magento. Create a swap file if you use a system with less than 2 GB of RAM to avoid failure in the update process.

Magento 2 Composer Requirements

You need the latest stable version of composer for Magento 2!

Magento 2 Web Service Requirements

 

  • Apache 2.4
  • Nginx 1.x

Magento 2 Database Requirements

 

Magento 2.4.xMySQL 8.0
MariaDB 10.4
Magento 2.3.xMySQL 5.6, 5.7
Magento 2.2.xMySQL 5.6, 5.7
Magento 2.1.xMySQL 5.6
(For Magento 2.1.2 and higher, use MySQL 5.7)
Magento 2.0.xMySQL 5.6

Other databases compatible with Magento: MySQL NDB Cluster 7.4.*, Percona 5.7, MariaDB 10.0, 10.1, 10.2 and other binary-compatible MySQL technologies.

Magento 2 PHP Requirements

  • 8.1.x (For Magento 2.4.x)
  • 7.4.x, 7.3.x (For Magento 2.3.x)
  • ~7.2.x

Required PHP extensions

  • ext-bcmath
  • ext-ctype
  • ext-curl
  • ext-dom
  • ext-fileinfo
  • ext-gd
  • ext-hash
  • ext-iconv
  • ext-intl
  • ext-json
  • ext-libxml
  • ext-mbstring
  • ext-openssl
  • ext-pcre
  • ext-pdo_mysql
  • ext-simplexml
  • ext-soap
  • ext-sockets
  • ext-sodium
  • ext-xmlwriter
  • ext-xsl
  • ext-zip
  • lib-libxml
  • lib-openssl

Additionally Adobe Commerce requires:

  • ext-spl

PHP OPcache

Enable PHP OPcache for performance reasons.

PHP Settings

Important PHP settings such as memory_limit must be configured to avoid common problems while using Magento 2.4.

Elasticsearch

It is mandatory to use Elasticsearch in Magento 2.4.x for search.

Magento no longer supports Elasticsearch 2.x, 5.x, and 6.x. Elasticsearch 7.17.x. is the recommended version.

Magento 2 SSL Requirements

  • A Security certificate for HTTPS.
  • Self-signed SSL certificates are not supported.
  • Transport Layer Security (TLS) requirement – PayPal and repo.magento.com both require TLS 1.2 or later.

Required system dependencies

  • bash
  • gzip
  • lsof
  • mysql
  • mysqldump
  • nice
  • php
  • sed
  • tar

Magento 2 Mail Server

  • Mail Transfer Agent (MTA)
  • SMTP server

Technologies Magento can use

  • Redis version 6.2
  • Varnish version 7.0
  • RabbitMQ 3.9.x
  • Elasticsearch 6.8 (Magento 2.3.4 and lesser)
  • Elastic Search 7.17.x

Magento 2 Browsers Support

  • Microsoft Edge latest – 1
  • Firefox latest -1
  • Chrome latest, latest–1 (any operating system)
  • Safari latest, latest–1 (Mac OS only)
  • Safari Mobile for iPad 2, iPad Mini, iPad with Retina Display (iOS 12 or later), for desktop storefront
  • Safari Mobile for iPhone 6 or later; iOS 12 or later, for mobile storefront
  • Chrome for mobile latest–1 (Android 4 or later) for mobile storefront

Note: Here, latest–1 means one major version earlier than the latest released version.

Magento Commerce only (For Magento 2.3.0)

  • Three master databases
    Enjoy scalability advantages for different functional areas of the Magento application such as checkout, orders, and all remaining Magento 2 application tables with these master database.

Optional (For Magento 2.3.0)

  • php_xdebug 2.5.x or later (development environments only; can have an adverse effect on performance)
  • mcrypt
  • PHPUnit (as a command-line tool) 6.2.0

This is it!

Fulfill the above Magento 2 System Requirements and make your E-commerce store a better platform by upgrading to Magento 2!

Upgrade to Magento 2 and enjoy all the new features that it has to offer 🙂

Additionally, for Magento 2 Enterprise version, you will need:

  • PHP extension: bc-math;
  • Apache Solr 4.x;
  • RabbitMQ 3.5;
  • MySQL 5.6, MariaDB, Percona.

I hope you got everything you were looking for to move to Magento 2. It is highly recommended that you use the latest Magento 2 version for your E-commerce store as it is beneficial for business as well as provides enhanced security.

I would be pleased to solve any further doubts or help you any time. Give me a holler whenever you stuck with a query. And yes, rate the article with 5 stars if you find it useful.

CTA_Meetanshi

5
(based on 33 Reviews)
Magento 2.x System RequirementsAuthor Magento Badge

Sanjay Jethva

Sanjay is a co-founder at Meetanshi. He is a Certified Magento Developer who loves creating Magento E-commerce solutions. Owing to his contributions in Magento Forums and posting solutions, he is among the top 50 contributors of the Magento community in 2019. When he is not engrossed with anything related to Magento, he loves to play cricket.

5 Comments

Leave a Reply

Your email address will not be published.