How To Fix “Indexer Reindex Required” Error In Magento 2

Ever faced an issue of the Customer Grid Indexer not working, when reindexing via CLI?!

Me too!!!

Sometimes, while running a command in Magento 2, “indexer re-index required” error is faced.

This is due to an issue in Magento 2 table. The table might have been corrupted in the database where it existed but something was missing.

Run the command php bin/magento indexer:status to check the status of indexer:

Design Config Grid: Reindex required
Customer Grid: Reindex required
Category Products: Ready
Product Categories: Ready
Product Price: Ready
Product EAV: Ready
Catalog Search: Reindex required
Stock: Ready Catalog Rule Product: Ready
Catalog Product Rule: Ready

When you run the command php bin/magento indexer:reindex – you get the error as shown below:

"Indexer Reindex Required" Error In Magento 2

Method To Fix Indexer ReIndex Required Error in Magento 2:

Go to C:xamppmysqldatamag232

Locate customer_grid_flat.ibd table on the customer grid.

Rename it to customer_grid_flat.ibd.old

That’s it.

Once the issue is solved, you can run the command – php bin/magento indexer:reindex without any issue as shown below:

Solved - Magento 2 Reindex Failed On Customer Grid

Do share the solution with the Magento community via social media.

Thanks.

Also Read:

Table of Contents