Magento 2.x System Requirements

Magento 2.x System Requirements

Since Magento 2 was released, it introduced the user-friendly interface, flexibility, advanced functionalities and enhanced security for the E-commerce websites. Magento 2 versions have all you need to grow your business even faster and control the store in a better way.

To avail all the benefits, install Magento 2 right away and grow your business! Here’s the first step towards installing Magento 2 and the minimum system requirements for installing Magento 2 to move from the older Magento versions! Magento 2 System Requirements include required OS, memory requirements, supported browsers, additional tools to install and other required settings.

Magento 2 System Requirements

Operating Systems Requirements

Linux distributors such as CentOS, Ubuntu, Debian or RedHat Enterprise Linux are easy to install Magento 2.

Memory Requirement

One will need up to 2GB RAM to update Magento. Create a swap file if you use a system with less than 2 GB of RAM to avoid failure in the update process.

Magento 2 Composer Requirements

You need the latest stable version of composer for Magento 2 extension development!

Magento 2 Web Service Requirements

  • Apache 2.2 or 2.4
  • Nginx 1.8

Magento 2 Database Requirements

Magento 2.0.xMySQL 5.6
Magento 2.1.xMySQL 5.6
(For Magento 2.1.2 and higher, use MySQL 5.7)
Magento 2.2.xMySQL 5.6, 5.7
Magento 2.3.xMySQL 5.6, 5.7

Other databases compatible with Magento: MySQL NDB Cluster 7.4.*, Percona 5.7, MariaDB 10.0, 10.1, 10.2 and other binary-compatible MySQL technologies.

Magento 2 PHP Requirements

  • 5.6.x;
  • 5.5.x, for x>=22;
  • 7.0.2 to 7.1.0, except for 7.0.5.
  • 7.1.3+  7.2.x (for Magento 2.3.0)
  • 7.3 (for Magento 2.3.3)

Required PHP extensions:

  • curl;
  • gd, ImageMagick > 6.3.7;
  • intl;
  • mbstring;
  • mcrypt;
  • mhash;
  • openssl;
  • PDO/MySQL;
  • SimpleXML;
  • soap;
  • xml;
  • xsl;
  • zip;
  • json (PHP 7 only);
  • iconv (PHP 7 only)

Additional PHP extensions for Magento 2.2.x:

  • ctype
  • dom
  • spl
  • libxml

PHP extensions for Magento 2.3:

  • bc-math (Magento Commerce only)
  • hash
  • azip

PHP OPcache

Enable PHP OPcache for the perfomance reasons.

PHP Settings

Important PHP settings such as memory limit must be configured to avoid common problems while using Magento 2.3.

Magento 2 SSL Requirements

  • A Security certificate for HTTPS.
  • Transport Layer Security (TLS) requirement

Note: Self-signed SSL certificates are not supported.

Magento 2 Mail Server

  • Mail Transfer Agent (MTA)
  • SMTP server

Technologies Magento can use:

  • Redis version 3.2 (compatible with 2.4+ ) for page caching and session storage
  • Varnish version 4.x or 5.2
  • RabbitMQ 3.7.x (compatible with 2.0 and later)
  • Elasticsearch 5.2.x

Magento 2 Browsers Support

  • IE 11 or later
  • Microsoft Edge latest and the previous version
  • Firefox latest and the previous version
  • Safari and the previous version (for Mac OS)
  • Safari Mobile
  • Chrome

Magento Commerce only (For Magento 2.3.0)

  • Three master databases
    Enjoy scalability advantages for different functional areas of the Magento application such as checkout, orders, and all remaining Magento 2 application tables with these master database.

Optional (For Magento 2.3.0)

  • php_xdebug 2.5.x or later (development environments only; can have an adverse effect on performance)
  • mcrypt
  • PHPUnit (as a command-line tool) 6.2.0

This is it! Fulfill the above Magento 2 System Requirements and make your E-commerce store a better platform by upgrading to Magento 2!

Upgrade to Magento 2 and enjoy all the new features that it has to offer 🙂

Additionally, for Magento 2 Enterprise version, you will need:

  • PHP extension: bc-math;
  • Apache Solr 4.x;
  • RabbitMQ 3.5;
  • MySQL 5.6, MariaDB, Percona.

I hope you got everything you were looking for to move to Magento 2. It is highly recommended that you use the latest Magento 2 version for your E-commerce store as it is beneficial for business as well as provides enhanced security.

I would be pleased to solve any further doubts or help you any time. Give me a holler whenever you stuck with a query. And yes, rate the article with 5 stars if you find it useful.

CTA_Meetanshi

4.7
(based on 23 Reviews)

Sanjay is a co-founder at Meetanshi. He is a Certified Magento Developer who loves creating Magento E-commerce solutions. Owing to his contributions in Magento Forums and posting solutions, he is among the top 50 contributors of the Magento community in 2019. When he is not engrossed with anything related to Magento, he loves to play cricket.

Leave a Reply

SUBSCRIBE
3.8
(based on 5 Reviews)